Follow

Important information about the macOS 10.13.4 update:

Important information about the macOS 10.13.4 update:

We are aware that the macOS 10.13.4 update is temporarily not supported on the j5 USB display adapters. We have alerted Apple to this issue and are working hard to find a solution.

If you require mirror or extended mode displays, we recommend that you stay on macOS 10.13.3 or earlier at this time.

We thank you for your patience and will provide an update on this situation, as soon as we have further information to share.

Was this article helpful?
2 out of 2 found this helpful
Have more questions? Submit a request

Comments